Björn Schneider

My feedback

  1. 34 votes
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)

      We’ll send you updates on this idea

      8 comments  ·  General  ·  Admin →
      Björn Schneider supported this idea  · 
      Björn Schneider commented  · 

      You might use comments along with the version definitions, like requires.io (Python) does. In pip's requirements.txt you would write something like:

      Django==1.8.9 # gn.version>1.8.0,<1.9.0 gn.expires=2018-04-01

      ...which means "pin it to a version between 1.8.0 and 1.9.0" (that's a long term support version), but warn after April, 1st 2018 (when the support runs out).

      Similar schould work for other build systems, unfortunately not for npm - JSON files can't contain comments. Here you'd need to use an own sub-key, e.g.:
      ...
      "dependencies": {
      "webpack": "^2.7.0"
      },
      "gemnasium": {
      "webpack: {
      "expires": "2018-06-01"
      }
      },
      ...

      ...which would warn after July, 1st 2018 if you still use a 2.7 version of wepack.

      That's for the two packaging systems/languages I use and need support for. But I guess there are similar options for the other ones supported by Gemnasium.

    Feedback and Knowledge Base